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About Windows Help Project Editor
Windows Help Project Editor (WHPE) is the part of Microsoft Help Author that you use to create and edit
Help project files and to compile Help files from within Windows.
When you create a Help project file, you generally follow these steps:

Enter project information
Add the topic files to the project
Specify Help project options
Save your work
Compile the Help file
View the built Help file

Note: The Help Project Editor does not include features for every option available in Windows Help 
version 3.1. However, you can edit the Help project file by hand to add the features you want. You can 
still use the Help Project Editor after that, and it will not change any of the hand-edited features.

See Also
The Project Editor Window



The Project Editor Window
The Help Project Editor's main window displays the list of topic files (.RTF) for the current project. 
(However, when you create a new project, the main window starts out blank and untitled.) Topic files are 
listed relative to the directory where the Help project file resides. Double-clicking a file in the list starts 
your RTF editor and opens that topic file so you can edit it.
Note: If you change the size or position of the main window, the Help Project Editor saves those 
changes between sessions.

See Also
Adding Topic Files to the Help Project
Editing Topic Files



Adding Graphics to the Help Project
If you use graphics in your Help file, you have to tell the Help compiler where to find the bitmap files. If 
you are using the 3.1 Help compiler, you only need to define a bitmap directory. If you are using the 3.0 
Help compiler, you must list the name of each bitmap file you want included in the build.

To define a bitmap directory
1 From the Edit menu, choose Graphics.

The Graphics dialog box appears.
2 In the Directory box, type the name and full path of the bitmap directory you want to define.

Note: The bitmap directory path can be absolute or relative to the project root directory.
3 Choose OK.

To provide a list of bitmap filenames
1 From the Edit menu, choose Graphics.

The Graphics dialog box appears.
2 Type the name of the bitmap file, including the drive and path if necessary, in the File Names box and 

press ENTER.
Note: If you are using the 3.0 Help compiler for the build, you must list all bitmaps in the File Names 
box. If you are using the 3.1 Help compiler for the build, you need only list the filenames of bitmaps 
not residing in the bitmap directory.

3 Repeat step 2 until you have listed all the bitmaps you want to include.
4 Choose OK.

The Graphics dialog box also lets you copy or cut bitmap filenames from the File Names list box.

To cut or copy text in the File Names list box
1 Select the text you want to cut or copy.
2 Choose the Cut button to cut text.

Or choose the Copy button to copy the text onto the Clipboard.

If you have a text file that contains the list of bitmap filenames in it, you may want to open that file and 
copy those items to the Clipboard. Then you can use the Paste button to paste them into the Graphics 
dialog box.

To paste text from the Clipboard into the File Names list box
1 Place on the Clipboard the text that you want to paste into the File Names list box.
2 Choose the Paste button to paste text you have placed on the Clipboard.

See Also
Graphics Command



Adding Comments to the Help Project File
You can add comments to the beginning of the Help project file. These comments are for your use only. 
During the build, the Help compiler ignores all comments.

To add comments
1 From the Edit menu, choose Comments.

The Comments dialog box appears.
2 Type your comments in the edit box.

Text will automatically wrap in the Comments box. If you want to create a new line before the text 
wraps, press CTRL+ENTER.
If you want more space to view and enter your comments, you can change the size of the dialog box 
by dragging its window borders. The new size and screen position are saved from session to session.

3 Choose OK.

The Comments dialog box also lets you copy or cut comments as well as paste text into the Comments 
box.

To cut or copy text in the Comments box
1 Select the text you want to cut or copy.
2 Choose the Cut button to cut text.

Or choose the Copy button to copy the text onto the Clipboard.

To paste text from the Clipboard into the Comments box
1 Place on the Clipboard the text that you want to paste into the Comments box.
2 Choose the Paste button to paste text you have placed on the Clipboard.

See Also
Comments Command



Adding Topic Files to the Help Project
When you create a Help project file, you add all the topic files that you want to include in the build of the 
Help file.

To add a topic file to the Help project file
1 From the Edit menu, choose Add New Or Existing File.

The Add New Or Existing File dialog box appears.
2 If the file is on a different drive, select the drive you want from the Drives box.
3 In the Directories box, double-click the directory you want.    

Or press the UP ARROW or DOWN ARROW key to select the directory, and then press ENTER.
The current directory will initially be the same directory as the currently selected file in the project 
window.

4 In the File Name box, double-click the name of the file you want to add.    
Or select the file and choose OK.
The selected file is added at the end of the list of files in the project window.
If the selected file does not exist, the Help Project Editor asks you if you want to create a new, untitled
RTF topic file. If you choose OK, the Help Project Editor will start your RTF editor and create a new 
document with the filename you specified.

See Also
Add New or Existing File Command
Changing Your Default RTF Editor
Edit File Command
Editing Topic Files
Remove File Command
Removing Topic Files from the Help Project



hint
Windows displays the names of all RTF files in that directory (the type selected in the List Files Of Type 
box). The Help Project Editor offers only one file type: RTF. To change the type of file displayed, edit the 
filename extension in the File Name box and press ENTER.



hint
The current directory is represented by the open folder icon.
Instead of using the File Name and Directories list boxes to add a file, you can type the complete 
filename (and path, if necessary) in the File Name box and click OK.



Changing Your Default RTF Editor
When you install the Help Project Editor, it installs Word for Windows or the word processor of your 
choice as the RTF editor. The editor you choose is saved in the [EXTENSIONS] section of the WIN.INI 
file. The Help Project Editor uses the "rtf=" entry to open your RTF editor when you choose the Edit File 
command.
Ordinarily, to change your default RTF editor you must edit the WIN.INI file and restart Windows. To 
save you that trouble, simply click the Change button, and a Help macro will do the work for you.

To change your RTF editor
Click the following button.    

See Also
Edit File Command
Editing Topic Files



Your WIN.INI file has been modified. 

To continue
Return to the Help Project Editor and edit a topic file. 

You will be prompted to specify a new RTF editor.



Creating New Help Project Files
The first thing you do when you want to create a new Help file is create a Help project.

To create a new Help project file
From the File menu, choose New Project.

See Also
New Project Command
Opening an Existing Help Project



Defining New Context IDs
You can add new context IDs to the Help project file using the Define button in the Application Contexts 
dialog box.

To define a new context ID
1 From the Edit menu, choose Application Contexts.

The Application Contexts dialog box appears.
2 Select New Context from the list box.
3 Type a context number in the Context Number box.

Select the Display Numbers In Hexadecimal check box if you are using hexadecimal ID numbers.
4 Type a context string in the Help Context String box.
5 Choose the Define button.    

See Also
Application Contexts Command
Deleting Context IDs
Editing Context IDs
Mapping Application Context IDs
Updating Context IDs from a File



example
Help context strings and context numbers entered by hand in the Help project file are saved in this 
format:

[MAP]
Help_Context                 0xFF
Help context strings entered by hand do not use #define.



Deleting Context IDs
You can delete any context ID from the Help project file when it is no longer necessary or valid.

To delete a context ID
1 From the Edit menu, choose Application Contexts.

The Application Contexts dialog box appears.
2 Select the context ID you want to delete.
3 Choose the Delete button.

The Help Project Editor will display a dialog box to confirm the deletion if the context ID is not part of a
resource file.

See Also
Application Contexts Command
Defining New Context IDs
Editing Context IDs
Mapping Application Context IDs
Updating Context IDs from a File



Deleting Window Definitions
You can delete any secondary window definition that you have created.

To delete a window definition
1 From the Edit menu, choose Window Definitions.

The Window Definitions dialog box appears.
2 Select the name of the window you want to delete from the Window Names list box.

Note: The Delete button will dim if you select either the "main" or "New Window" name because you 
cannot delete those definitions.

3 Choose the Delete button.

See Also
Setting the Window's Position
Specifying Background Colors
Specifying Window Definitions
Window Definitions Command



Displaying a Project's Help File
After you have compiled a Help file, you can use the Help Project Editor to start Windows Help and open
the Help file of the current Help project.

To display the Help file of the current Help project
From the File menu, choose Run Help On (filename).

If the Help file did not build correctly, Windows Help displays an error message: either "File not found"
or "Help file damaged. Rerun setup." Try building the Help file again before choosing this command.

See Also
Run Help On Command



Editing Context IDs
You can edit context numbers and Help context strings. Although application context strings may also be
displayed, they cannot be edited.

To edit a context ID number or Help context string
1 From the Edit menu, choose Application Contexts.

The Application Contexts dialog box appears.
2 Select the context IDs you want to edit from the list box.
3 Edit the context number in the Context Number box.

Select the Display Numbers In Hexadecimal check box if you are using hexadecimal ID numbers.
4 Edit the context string in the Help Context String box.
5 Choose Define to save the changes without closing the dialog box.

Or choose OK to save the changes and close the dialog box.

See Also
Application Contexts Command
Defining New Context IDs
Deleting Context IDs
Mapping Application Context IDs
Updating Context IDs from a File



Editing Project Information
You can edit project-level information, including the title of the Help project file, the context ID for the 
Contents topic, and the version of the compiler to use for the build.

To edit project information
1 From the Edit menu, choose Project.

The Project dialog box appears.
2 In the Title box, type the name you want to appear in the title bar when the Help file is displayed.
3 In the Contents box, type the context string of the topic you want to designate as the Contents for 

your Help file.
4 Select the version of Help you want to use for this Help project.

Note: These option buttons correspond to the two versions of the Help compiler: HC30.EXE and 
HC31.EXE.

5 Choose OK.

See Also
Project Command



Editing Topic Files
You can edit any topic file without quitting the Help Project Editor.

To edit a topic file
Select the file you want to edit, and then choose Edit Topic from the Edit menu.

Or double-click the file.

See Also
Add New or Existing File Command
Adding Topic Files to the Help Project
Changing Your Default RTF Editor
Edit File Command
Remove File Command
Removing Topic Files from the Help Project



Mapping Application Context IDs
If you are including context-sensitive Help as a feature of your Help system, you can use the Help 
Project Editor to map context IDs in the application to context IDs in your topic files.
The Application Contexts dialog box displays all the context numbers, Help context strings, and 
application context strings entered for the current Help project file. This list of IDs represents the [MAP] 
and [ALIAS] sections of the Help project file.

To map context IDs
1 From the Edit menu, choose Application Contexts.

The Application Contexts dialog box appears.
2 Define the context ID mappings for this Help file.

Or enter the context ID mappings from an existing text file.
3 Select the Display Numbers In Hexadecimal check box if you are using hexadecimal ID numbers.
4 Choose Define to save the changes without closing the dialog box.

Or choose OK to save the changes and close the dialog box.

See Also
Application Contexts Command
Defining New Context IDs
Deleting Context IDs
Editing Context IDs
Updating Context IDs from a File



Opening an Existing Help Project
You can open any Help project file, whether or not you used the Help Project Editor to create it.

To open a Help project file
1 From the File menu, choose Open Help Project.

The Open Help Project dialog box appears.
2 If the file is on a different drive, select the drive you want from the Drives box.
3 In the Directories box, double-click the directory you want.    

Or press the UP ARROW or DOWN ARROW key to select the directory, and then press ENTER.
The current directory will initially be the same directory as the currently selected file in the project 
window.

4 In the File Name box, double-click the name of the file you want to open.    
Or select the file and choose OK.

See Also
Creating New Help Project Files
Open Help Project Command



hint
Windows displays the names of all files in that directory that are the type selected in the List Files Of 
Type box. The Help Project Editor offers only one file type: Project Files. To change the type of file 
displayed, edit the filename extension in the File Name box and press ENTER.
The current directory is represented by the open folder icon.



hint
Instead of using the File Name and Directories list boxes to add a file, you can type the complete path in
the File Name box and click OK.



Quitting the Help Project Editor
To quit the Help Project Editor

From the File menu, choose Exit.
Or double-click the Control-menu box.
If you are working on a Help project file and haven't saved your changes, the Help Project Editor will 
prompt you to save the file.

See Also
Exit Command



Removing Topic Files from the Help Project
If you no longer want to include a topic file in a Help project, you can remove it from the list of files.

To remove a topic file from the Help project file
1 Select the file you want to remove.
2 From the Edit menu, choose Remove File.

Or press DEL.

See Also
Add New or Existing File Command
Adding Topic Files to the Help Project
Changing Your Default RTF Editor
Edit File Command
Editing Topic Files
Remove File Command



Saving Help Project Files
Use the Save Project command to save changes to an existing Help project file. Use the Save Project 
As command to save a new (untitled) Help project file or to rename the current file under a new name.

To save changes to an existing Help project file
From the File menu, choose Save Project.

To save a new Help project file or save the current file under a different name
1 From the File menu, choose Save Project As.

The Save Project As dialog box appears.
2 If you want to save the file on a different drive, select the drive you want from the Drives box.
3 In the Directories box, double-click the directory in which you want to save the file.    

Or press the UP ARROW or DOWN ARROW key to select the directory, and then press ENTER.
4 In the File Name box, type a name for the file.    

The .HPJ extension is automatically assigned to the filename if you don't specify an extension. If you 
type an extension, it must be .HPJ.

5 Choose OK.

See Also
Save Project As Command
Save Project Command



hint
The current directory is represented by the open folder icon.



hint
Instead of using the File Name and Directories list boxes to save a file, you can type the complete path 
in the File Name box and click OK.



Setting the Window's Position
You can indicate the exact size and location of any Help window.

To set a window's size and position
1 From the Edit menu, choose Window Definitions.

The Window Definitions dialog box appears.
2 Select a window name in the Window Names list box.
3 Select the Set Window Position check box if you want to set the size and position of the main window.

If you are setting the position of a secondary window, this check box is automatically chosen for you.
4 Use the Window Position box to define the size and position of the window.

Or define the window's size and placement by typing the coordinates in the four edit boxes to the left 
of the Window Position box.    

Note: The window outline changes dynamically as you type.

The Window Position box consists of two rectangles: the large rectangle represents your Windows 
desktop, and the inside rectangle represents the window you are defining. The sizing handles let you 
change the window size directly by using the mouse, just as you would resize a real window on the 
desktop. You can also move the window to change the window's relative position on the desktop.

To move the window outline
1 Move the pointer inside the window, and press and hold down the mouse button.
2 Drag the window where you want it.

Note: As you move the window outline, the edit boxes to the left show the exact coordinates.

To resize the window outline
Drag a sizing handle in the direction you want to change the window.

Note: As you change the window outline's size, the edit boxes to the left show the exact coordinates.

See Also
Deleting Window Definitions
Specifying Background Colors
Specifying Window Definitions
Window Definitions Command



example
Windows Help uses a 1024-by-1024 coordinate system mapped onto the horizontal and vertical 
resolutions of your video card, so you'll have to perform some calculations to determine the exact pixel 
location. For example, if the resolution of your video card is horiz by vert pixels, and the horizontal and 
vertical locations you specify are at Windows Help coordinates x and y, then the x coordinate of the 
upper-left corner is at the pixel given by the following formula:

x * (horiz/1024)
The y coordinate of the upper-left corner is at the pixel given by the following formula:

y * (vert/1024)
For example, the upper-left corner coordinates for secondary windows of type type1 are (0,0), the upper-
left corner of the screen.
The second two numbers define the normal width and height of the window, again in terms of the 
Windows Help coordinate system. Type1 windows are specified with a width of 511 and a height of 511. 
A standard VGA card has a resolution of 640-by-480 pixels, so the width is actually the following number
of pixels:

511 * (640/1024) = 319
The height is actually the following number:

511 * (480/1024) = 240
In other words, type1 windows take up approximately one quarter of the area of the Windows Help 
screen (half the width multiplied by half the height).
To convert from pixels to Windows Help coordinates, invert the ratio between Windows Help's resolution 
and the video resolution. Again, assuming the resolution of your video card is horiz by vert pixels, and 
the horizontal and vertical locations (or dimensions) you want are x and y pixels, the x coordinate (or 
width), in Windows Help coordinates, is as follows:

x * (1024/horiz)
The y coordinate (or height), in Windows Help coordinates, is:

y * (1024/vert)
Because the Windows Help coordinate system ranges from 0 through 1023 in both directions, the 
horizontal position plus the width must be less than 1023. Similarly, the vertical position plus the height 
must be less than 1023.



Specifying Background Colors
You can specify the background color for the main topic area and the nonscrolling region of a window.

To specify background colors
1 From the Edit menu, choose Window Definitions.

The Window Definitions dialog box appears.
2 Select a window name in the Window Names list box.
3 Select the color you want for the topic area from the Scrolling Region drop-down list box.

Or choose Other to pick a custom color from the Windows Color dialog box.
An example of your color selection appears in the display box to the left of the color box.
Note: The default selection means that Windows Help will match the user's default screen color.

4 If this window uses a nonscrolling region, select the color you want from the Nonscrolling Region 
drop-down list box.
Note: Refer to step 3 for details.

5 Choose OK.

See Also
Deleting Window Definitions
Setting the Window's Position
Specifying Window Definitions
Window Definitions Command



Specifying the Level of Compression
If you want to reduce the size of the built Help file, you can specify the level of compression, or you can 
use no compression during the build.

To specify the level of compression
1 From the Edit menu, choose Compression.

The Compression dialog box appears.
2 Select the level of compression you want.

If you are using the 3.0 Help compiler to build the file, the Medium compression option will be 
dimmed.

3 Select the Use Old Keyphrase File check box if you want the Help compiler to use an existing 
keyphrase file.
You use an existing keyphrase file if you want to speed up the build process. To achieve maximum 
compression, you should not use the old keyphrase file.
The check box for using the old keyphrase file is dimmed unless the compression level is set to High.

4 Choose OK.

See Also
Compression Command



Specifying Window Definitions
If you want to create a secondary window for your Help file or modify the way the main Help window 
appears, you can use the Help Project Editor to define the window characteristics for your Help file.
The Window Definitions dialog box includes all the attributes that you can specify for the main window or
for a secondary window that you create.

To define the main Help window
1 From the Edit menu, choose Window Definitions.

The Window Definitions dialog box appears.
2 Select "main" from the Window Names list box.

Note: The name "main" is dimmed in the Name box because you cannot change the name of the 
primary Help window.

3 Type the caption you want to appear in the main window's title bar.
Note: If you entered a title in the Project dialog box, that title will appear in this box as the window 
caption. You can edit the caption here or in the Project dialog box.

4 Specify a background color for the scrolling and nonscrolling areas, if desired.
5 Select the Set Window Position check box if you want to change the position of the main Help 

window.
Note: The window position options for the main window are not available unless you select this check 
box.

6 Specify the size and position of the main window, if desired.
7 Choose Define to save the changes without closing the dialog box.

Or choose OK to save the changes and close the dialog box.

To define a secondary window
1 From the Edit menu, choose Window Definitions.

The Window Definitions dialog box appears.
2 Select New Window from the Window Names list box.
3 Type the name you want to give to the secondary window in the Name box.

Note: The default name "new" appears in the Name box when you select a New Window class. You 
can edit this name or type over it.

4 Type the caption you want to appear in the window's title bar.
Note: The default caption "New Window" appears in the Caption box when you select a New Window 
class. You can edit this name or type over it.

5 Select the Stay On Top check box if you want the secondary window to stay on top of other windows 
while the user has this Help window open.

6 Specify a background color for the scrolling and nonscrolling areas, if desired.
7 Specify the size and position of the secondary window.
8 Choose Define to save the changes without closing the dialog box.

Or choose OK to save the changes and close the dialog box.

See Also
Deleting Window Definitions
Setting the Window's Position
Specifying Background Colors
Window Definitions Command



Starting the Build
You can use the Help Project Editor to start the Help compiler and build Help files from within Windows. 
During the build, the Help Project Editor shows the messages or error output in a compilation window.

To start a build
1 From the Compile menu, choose Start.

The Compilation in Progress window appears, showing the progress of the build and any errors that 
might occur.
Note: If you are using the 3.0 Help compiler for the build, the error output must be directed to a file; 
you will not see the error output during the build.

See Also
Start Command
Viewing Error Messages



Updating Context IDs from a File
If you or the application developers create a file containing the application context IDs and ID numbers, 
you can read this information into the Help project file rather than entering it by hand.

To enter or update context IDs from a file
1 From the Edit menu, choose Application Contexts.

The Application Contexts dialog box appears.
2 Choose the Update button.

The Update Contexts From Application File dialog box appears.
3 If the file is on a different drive, select the drive you want from the Drives box.
4 In the Directories box, double-click the directory you want.    

Or press the UP ARROW or DOWN ARROW key to select the directory, and then press ENTER.
5 In the File Name box, double-click the name of the file that has the context IDs.    

Or select the file and choose OK.    

To enter or update context IDs from more than one file
1 Create a file that contains all the files you want to use in the update.

You can use the #include directive to include the extra files.
2 From the Edit menu, choose Application Contexts.

The Application Contexts dialog box appears.
3 Choose the Update button.
4 Follow steps 3 - 5 above to open the resource file.

See Also
Application Contexts Command
Defining New Context IDs
Deleting Context IDs
Editing Context IDs
Mapping Application Context IDs



hint
Windows displays the names of all files in that directory that are the type selected in the List Files Of 
Type box. The Help Project Editor offers only one file type: Header Files. To change the type of file 
displayed, edit the filename extension in the File Name box and press ENTER.



hint
The current directory is represented by the open folder icon.
Instead of using the File Name and Directories list boxes to choose the file, you can type the complete 
path in the File Name box and click OK.



example
Application context strings, Help context strings, and context ID numbers entered or updated from a file 
are saved in this format:

[ALIAS]
APPLICATION_CONTEXT = Help_Context
[MAP]
#define APPLICATION_CONTEXT      0xFF
If the Help context string is the same as the application context string, the entry in the [ALIAS] section is 
omitted. The #define appears with the application context ID in the [MAP] section because the ID was 
entered from a file.



Viewing Error Messages
The View Errors window displays the error messages that occur during a build or upon opening a Help 
project file, if the Help Project Editor detects errors. You can choose to show or hide this window by 
using the View Errors command on the Compile menu.

To show the View Errors window
From the Compile menu, choose View Errors.

The View Errors window appears and displays the error messages from the most recent build of the 
Help file. A check mark appears to the left of the command on the menu to indicate that the window is 
open.
Note: Once displayed, you can change the size and position of the View Errors window. The Help 
Project Editor automatically saves your changes between sessions.

To hide the View Errors window
From the Compile menu, choose View Errors.

Or double-click the Control-menu box.
The View Errors window closes.

See Also
Starting the Build
View Errors Command



File Menu Commands
Choose the command you want Help on.

Commands
New Project Command
Open Help Project Command
Save Project Command
Save Project As Command
Run Help On Command
Exit Command



New Project Command
Creates a new, untitled project in the Help Project Editor window.
When you choose this command, the Help Project Editor lets you save changes to the current Help 
project file before opening a new project.

See Also
Creating New Help Project Files



Open Help Project Command
Opens an existing Help project file.
When you choose this command, the Help Project Editor lets you save changes to the current Help 
project file before opening a new project.
If opening the Help project file creates any warnings or errors, the Help Project Editor displays the errors
and warnings in the View Errors window.
Note: If the Help project file was created and saved using the Help Project Editor, it will not produce any 
errors.

See Also
Opening an Existing Help Project



Save Project Command
Saves changes to the current Help project file.
If the Help project file is untitled, the Help Project Editor prompts you for a name.

See Also
Saving Help Project Files



Save Project As Command
Saves the current Help project file under a new name.

See Also
Saving Help Project Files



Run Help On filename Command
Starts Windows Help and opens the latest build of the current Help project file.
If the Help file did not build correctly, Windows Help displays an error message: either "File not found" or
"Help file damaged. Rerun setup."
If the current project is a new, untitled Help project file, this command is dimmed.

See Also
Displaying a Project's Help File



Exit Command
Exits the Help Project Editor and closes the current Help project file.
If a project is currently open and has been edited, the Help Project Editor prompts you to save changes 
before closing the project.

See Also
Quitting the Help Project Editor



Edit Menu Commands
Choose the command you want Help on.

Commands
Add New or Existing File Command
Remove File Command
Edit File Command
Project Command
Comments Command
Compression Command
Application Contexts Command
Graphics Command
Window Definitions Command



Add New or Existing File Command
Adds topic files to the current Help project.

See Also
Adding Topic Files to the Help Project
Editing Topic Files
Removing Topic Files from the Help Project



Remove File Command
Removes from the Help project file the currently selected file in the project window.

See Also
Adding Topic Files to the Help Project
Editing Topic Files
Removing Topic Files from the Help Project



Edit File Command
Starts your RTF editor, if it is not already running, and opens the file currently selected in the project 
window.
Choosing this command is the same as double-clicking the file.

See Also
Adding Topic Files to the Help Project
Editing Topic Files
Removing Topic Files from the Help Project



Project Command
Displays a dialog box where you can edit project-level information, including the title of the file, the 
context id for the Contents topic, and the Help compiler (HC30.EXE or HC31.EXE) to use for the build.

See Also
Editing Project Information



Comments Command
Displays a dialog box where you can enter comments that will appear at the beginning of the Help 
project file.

See Also
Adding Comments to the Help Project File



Compression Command
Displays a dialog box where you can set the level of compression to use during the build.

See Also
Specifying the Level of Compression



Application Contexts Command
Displays a dialog box where you can map context IDs used for context-sensitive Help.

See Also
Defining New Context IDs
Deleting Context IDs
Editing Context IDs
Mapping Application Context IDs
Updating Context IDs from a File



Graphics Command
Displays a dialog box where you can enter a bitmap directory or list bitmaps to include in the build.

See Also
Adding Graphics to the Help Project



Window Definitions Command
Displays a dialog box where you can enter main and secondary window definitions. This command is 
available only if you are using the 3.1 Help compiler for the build.

See Also
Deleting Window Definitions
Setting the Window's Position
Specifying Background Colors
Specifying Window Definitions



Compile Menu Commands
Choose the command you want Help on.

Commands
Start Command
View Errors Command



Start Command
Starts compiling the current Help project and shows the progress of the build in an MS-DOS box.
If the current Help project file includes unsaved changes, the Help Project Editor prompts you to save 
the changes before it begins compiling.

See Also
Starting the Build



View Errors Command
Displays or hides the View Errors dialog box.
A check mark appears next to this command when the View Errors dialog box is visible.
If you choose the View Errors command when you are not compiling, the Help Project Editor displays 
the errors from the most recent build of the current Help project, even if the build occurred in a previous 
session.

See Also
Viewing Error Messages



Help Menu Commands
Choose the command you want Help on.

Commands
Contents Command
Search For Help On Command
How To Use Help Command
About Help Project Editor Command



Contents Command
Displays the Contents topic for the Help Project Editor's Help file.



Search For Help On Command
Displays the Search dialog box, which contains all the Help keywords for the Help Project Editor.
By typing or selecting a keyword, you can search for and go to specific Help topics.



How To Use Help Command
Displays the Contents for the How to Use Help topics.
Choosing this command is the same as pressing F1 when you are using Help.



About Help Project Editor Command
Shows information about the Help Project Editor, including version number and copyright.



Specify RTF Editor
This dialog box lets you indicate which word processor or editor you want to use for editing Help topic 
files. The recommended word processor is Word for Windows version 1.1 or 2.0. If you do not have 
Word for Windows, you can specify another editor; however, the editor must be able to save files in Rich 
Text Format (RTF).
This dialog box has the following option:

File Name
Type the name and path (including drive and directory) of the RTF editor you want to use, and 

then choose OK.
Or choose the Browse button to find and select an RTF editor.
The Help Project Editor saves your choice in the "rtf=" line in the [EXTENSIONS] section of the 
WIN.INI file.



Browse
Use this dialog box to find and select the RTF editor you want to use.
This dialog box has the following options:

File Name
Select the name of the editor you want to use, and then choose OK.

Or type the filename in this box, and then choose OK.
If necessary you can enter a full path in this box, including drive and directories.

If the file you want to choose does not appear in the File Name list box, you can change drives or 
directories, or specify a different file extension.

Directories
Select the directory that contains the RTF editor you want to use.

When you select a directory, the files in that directory appear in the File Name box.
If the editor you want to use does not appear in the Directories list box, you may have to change drives 
by using the Drives option.

List Files Of Type
If necessary, select a different type of file or file extension.

Drives
Open the drop-down list box and select the drive that contains the RTF editor you want to use.

When you change drives, the directories on that drive appear in the Directories box.
If the drive you want to change to does not appear in the Drives list box, it may be a network drive that 
you have not connected to. First connect to the drive and then use this dialog box option.



Open Help Project
Use this dialog box to find and select Help project files you want to open.
This dialog box has the following options:

File Name
Select the name of the file you want, and then choose OK.

Or type the filename in this box, and then choose OK.
If necessary you can enter a full path in this box, including drive and directories.

If the file you want to open does not appear in the File Name list box, you can change drives or 
directories, or specify a different file extension.

Directories
Select the directory that contains the Help project file you want to open.

When you select a directory, the files in that directory appear in the File Name box.
If the file you want to open does not appear in the Directories list box, you may have to change drives by
using the Drives option.

List Files Of Type
Since the Help Project Editor only works with Help project files (.HPJ), you cannot use this option to 
specify a different file type or file extension.

Drives
Open the drop-down list box and select the drive that contains the Help project file you want to 

open.
When you change drives, the directories on that drive appear in the Directories box.

If the drive you want to change to does not appear in the Drives list box, it may be a network drive that 
you have not connected to. First connect to the drive and then use this dialog box option.



Save Project As
Use this dialog box to save new, untitled Help project files or to rename existing Help project files under 
a different name.
This dialog box has the following options:

File Name
Type the name of the file you want to save, and then choose OK.

Or select the filename from the list box, modify its name, and then choose OK.
If necessary you can enter a full path in this box, including drive and directories.

To save the file to a different drive or directory, you must first change drives or directories.

Directories
Select the directory where you want to save the Help project file.

When you select a directory, the files in that directory appear in the File Name box.
To save the file to a different drive, you must first change drives.

Save File As Type
Since the Help Project Editor only works with Help project files (.HPJ), you cannot use this option to 
specify a different file type or file extension.

Drives
Open the drop-down list box and select the drive where you want to save the Help project file.

When you change drives, the directories on that drive appear in the Directories box.
If the drive you want to save to does not appear in the Drives list box, it may be a network drive that you 
have not connected to. First connect to the drive and then use this dialog box option.



Add New or Existing File
Use this dialog box to find and select Help project files you want to add to the project window.
This dialog box has the following options:

File Name
Select the name of the file you want, and then choose OK.

Or type the filename in this box, and then choose OK.
If necessary you can enter a full path in this box, including drive and directories.

If the file you want to add does not appear in the File Name list box, you can change drives or 
directories, or specify a different file extension.

Directories
Select the directory that contains the Help project file you want to add.

When you select a directory, the files in that directory appear in the File Name box.
If the file you want to add does not appear in the Directories list box, you may have to change drives by 
using the Drives option.

List Files Of Type
Open the drop-down list box and select the type of file you want displayed in the File Name box.

The Help Project Editor gives you only two choices: RTF Files and All Files.

Drives
Open the drop-down list box and select the drive that contains the Help project file you want to 

add.
When you change drives, the directories on that drive appear in the Directories box.

If the drive you want to change to does not appear in the Drives list box, it may be a network drive that 
you have not connected to. First connect to the drive and then use this dialog box option.



Project
Use this dialog box to enter information about the Help project.
This dialog box has the following options:

Title
Type the name you want to appear in the title bar when the Help file is displayed.

Contents
Type the context string of the topic you want to designate as the Contents for your Help file.

Help Version
Select the appropriate option button to indicate the version of the Help compiler you want to use 

to build your Help file.



Comments
Use this dialog box to enter personal comments about the Help project file or file options.
This dialog box has the following options:

Comments Window
Type any comment text you want to add to the Help project file in the space provided by this 

window.
You can change the size of (or maximize) the Comments dialog box to create a text window that is 
comfortable to use. Any changes you make to the size or position of this dialog box are saved from 
session to session.

Cut
Choose the Cut button to cut comment text you have selected from the Comments window and 

place it on the Clipboard.

Copy
Choose the Copy button to copy comment text you have selected to the Clipboard.

Paste
Choose the Paste button to paste text you have placed on the Clipboard into the Comments 

window.



Compression
Use this dialog box to specify the level of compression you want to use for the build.
This dialog box has the following options:

Compression
Use these options to specify the amount of compression.

Select To specify
None No compression.
Medium Medium compression (approximately 40%).
High High compression (approximately 50%).

The Medium compression option is unavailable if you are using the 3.0 Help compiler.

Use Old Keyphrase File
Select this check box if you want to use the keyphrase table from a previous build of the Help file.

This option is unavailable unless you select High compression.



Application Contexts
Use this dialog box to map context IDs in the application to your Help topic context strings.
This dialog box has the following options:

Context Number
This box shows the context number corresponding to the selected application string.

Type a new context number or edit the current context number shown in this box.

Help Context String
This box shows the Help context string corresponding to the selected context number.

Type a new context string or edit the current context string shown in this box.

Application Context String
This box shows the application context string, if any. The Help Project Editor displays this string so that 
you can correctly map your Help context strings to the appropriate application context strings. You 
cannot, however, edit or modify an application context string.
Note: Context IDs entered by hand do not have an application context string.

Context IDs List Box
This list box shows all the context IDs you have entered or read in from a file.

Select the context ID you want to edit. Or select New Context to define a new context string for 
the Help project file.

Define
Choose this button to define context IDs you have entered by hand in the Context Number and 

Help Context String boxes, or to save changes after you have mapped an application string to one of your
Help context strings.

Delete
Choose this button to remove a context ID from the Help project file.

Update
Choose this button to have all the context IDs entered or updated from a header file.

It is usually preferable to use this option to enter context IDs if the IDs are generated by developers 
and maintained in one of the application's resource files (.H file, for example).
Note: Context IDs entered from a file have an application context string.

Display Numbers In Hexadecimal
Select this check box if you want the Help Project Editor to display context numbers in 

hexadecimal.



Update Contexts from Application File
Use this dialog box to find and select resource files that contain the context IDs you want to map to Help
topics in your Help file.
This dialog box has the following options:

File Name
Select the name of the resource file you want, and then choose OK.

Or type the filename in this box, and then choose OK.
If necessary you can enter a full path in this box, including drive and directories.

If the file you want to open does not appear in the File Name list box, you can change drives or 
directories, or specify a different file extension.

Directories
Select the directory that contains the resource file you want to open.

When you select a directory, the files in that directory appear in the File Name box.
If the file you want to open does not appear in the Directories list box, you may have to change drives by
using the Drives option.

List Files Of Type
The Help Project Editor only offers the Header File type (.H). If you want to see a different type of file, 
type the file extension you want in the File Name box.

Drives
Open the drop-down list box and select the drive that contains the resource file you want to open.

When you change drives, the directories on that drive appear in the Directories box.
If the drive you want to change to does not appear in the Drives list box, it may be a network drive that 
you have not connected to. First connect to the drive and then use this dialog box option.



Graphics
Use this dialog box to list the names of bitmaps that are to be included in the build or to tell the Help 
compiler where the bitmap files reside in the Help project.
This dialog box has the following options:

Directory
This box shows the current bitmap directory.

To define a new or different bitmap directory, type its path and name in this box.

File Names
This edit box shows all the bitmap filenames for the current Help project.

To add a bitmap to the list, type the name of the file, including the drive and path if necessary, in 
this edit box.

Note: If you are using the 3.0 Help compiler for the build, you must list all bitmaps in this edit box. If 
you are using the 3.1 Help compiler for the build, you need only list the filenames of bitmaps not 
residing in the bitmap directory.

Cut
Choose the Cut button to cut text you have selected from the Graphics window and place it onto 

the Clipboard.

Copy
Choose the Copy button to copy text you have selected to the Clipboard.

Paste
Choose the Paste button to paste text you have placed on the Clipboard into the Graphics 

window.



Window Definitions
Use this dialog box to define main or secondary window attributes.
This dialog box has the following options:

Window Names
This box shows the name of the main Help window and any secondary windows you have defined.

To edit the attributes of a window, select its name in this list box.
Or select New Window to create a secondary window definition.

Name
This box shows the name of the window definition you are currently editing.

Type the name of the secondary window and then define its attributes.
Note: If you select "main" as the window name, the name "main" is dimmed in this box because it 
cannot be changed.

Caption
This box shows the caption that will appear in the window's title bar.

Type the name of the caption you want for this window.

Stay On Top
Select this check box if you want the window to stay on top of other windows while the user has it 

open.
Note: If you select "main" as the window name, the Stay On Top check box is dimmed because the 
main window cannot be defined as on top.

Define
Choose the Define button to enter attributes for a new window definition or to save changes to a 

window definition without closing the dialog box.

Delete
Choose the Delete button to remove a window definition you have created.

Background Colors
This box shows the background color you have assigned to the topic's scrolling and nonscrolling 
regions. It has two drop-down list boxes: Scrolling Region and Nonscrolling Region.

To change the background color of the scrolling or nonscrolling region, select a color from the 
drop-down list box.

An example of your color selection appears in the display box to the left of the color box.
Note: The default selection means that Windows Help will match whatever color the user has chosen 
for the window background using the Windows Control Panel application.

Set Window Position
Select this check box if you want to specify an exact size and position for the window.

Note: The window position options for the main window are not available until you select this check 
box.

Window Position
The Window Position box consists of two rectangles: the large rectangle represents your Windows 
desktop, and the inside rectangle represents the window you are defining. The sizing handles let you 
change the window size directly by using the mouse, just as you would resize a real window on the 



desktop. You can also move the window to change the window's relative position on the desktop.
Drag a window border to change the size of the window.

Or move the pointer inside the window outline and drag the entire window to move it to a new location.
Note: As you move or resize the window outline, the edit boxes to the left show the exact coordinates.

Top
This box shows the vertical coordinate (in a 1024-by-1024 coordinate system) of the upper-left corner of 
the window.

If you want to change the vertical coordinate, type a different number in this box.
The window outline in the Window Position box adjusts dynamically as you type.

Left
This box shows the horizontal coordinate (in a 1024-by-1024 coordinate system) of the upper-left corner 
of the window.

If you want to change the horizontal coordinate, type a different number in this box.
The window outline in the Window Position box adjusts dynamically as you type.

Width
This box shows the width (in a 1024-by-1024 coordinate system) of the window.

If you want to change the width, type a different number in this box.
The window outline in the Window Position box adjusts dynamically as you type.

Height
This box shows the height (in a 1024-by-1024 coordinate system) of the window.

If you want to change the height, type a different number in this box.
The window outline in the Window Position box adjusts dynamically as you type.



Compilation in Progress
The Compilation in Progress window displays the progress of the build as it occurs in MS-DOS. The 
particular status and warning messages that you see depend on the options you have set in the 
[OPTIONS] section of the Help project file. (Note: These options must be entered by hand; they cannot 
be edited by using the Help Project Editor.)
If you are using the 3.1 Help compiler for the build, the Help Project Editor uses the ERRORLOG option 
to save to a file the errors being displayed on the screen. If you are using the 3.0 Help compiler for the 
build, the error output must be directed to a file; you will not see the error output during the build.



View Errors
The View Errors window displays the error messages that occur during a build or upon opening a Help 
project file, if the Help Project Editor detects errors. The displayed errors are also written to a file with the
same base name as the Help project file but with an .ERR extension. The View Errors window can be 
hidden or shown by using the View Errors command on the Compile menu.
The Help Project Editor saves the size and position of the View Errors window between sessions.



About Help Project Editor
This dialog box shows information about the Help Project Editor, including version number and 
copyright.
This dialog box has no options.



Help Project Editor Keys
Use the following keys in the Help Project Editor:

To Press

Remove a file from the project window DEL or 
SHIFT+DEL

Move the highlight to the previous (up) or 
next (down) file in the project window

UP or DOWN 
ARROW




